This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our private policy>

Security Advisory- Web Interface Authentication Bypass Vulnerability in Huawei Tecal RH2285 V2 Server

  • SA No:Huawei-SA-20130718-TecalRH2285V2
  • Initial Release Date: 2013-07-18
  • Last Release Date: 2013-07-18

Tecal RH2285 V2 is a next-generation 2 U 2-socket rack server. Featuring two Intel® Xeon® E5-2400 series processors, the RH2285 V2 provides large storage capacity, flexible scalability, and superb cost-effectiveness, which is an ideal hardware platform for big data and distributed storage applications.

The Tecal RH2285 V2 server contains a web interface authentication bypass vulnerability. This vulnerability may cause information leaks or modification. (Vulnerability ID: HWNSIRT-2013-0304).

This vulnerability was first reported by Bai Gali of QIHU360. Huawei would like to thank Bai Gali and QIHU360 for reporting these issues and for working with us to help protect the security of our customers.

Temporary fixes and upgrade versions are currently available. Detailed information is listed below.

Products Name

Products Version

Tecal RH2285 V2

V100R002C00SPC103
V100R002C00SPC101
V100R002C00

This vulnerability may cause information leaks or modification.

The vulnerability classification has been performed by using the CVSSv2 scoring system (http://www.first.org/cvss/).

The score of the vulnerability is following:

Base Score: 8.5(AV:N/AC:M/Au:S/C:C/I:C/A:C)

Temporal Score: 7.3 (E:F/RL:T/RC:C)

Overall Score: 7.3

  1. Vulnerability exploitation prerequisites:

An attacker can access the web management interface of Tecal RH2285 V2

An attacker gains legitimate login permissions of the common user.

  1. Vulnerability details:

The attackers may add illegitimate administrator accounts and bypass the authentication mechanism.

 

Customers should contact Huawei TAC (Huawei Technical Assistance Center) to request the upgrades. For TAC contact information, please refer to Huawei worldwide website at http://www.huawei.com/en/security/psirt/report-vulnerabilities/index.htm.


Solution

The web background service verifies the validity of all the requested data.

This vulnerability has been fixed in the following version:

 

Products
Name

Products Version

Patches Version

Release
Data

Tecal RH2285 V2

V100R002C00SPC103
V100R002C00SPC101
V100R002C00

V100R002C00SPC107

Released

 


This vulnerability was reported by Bai Gali of QIHU360. Huawei PSIRT is not aware of any public announcements or malicious use of this vulnerability in this advisory. 

For security problems about Huawei products and solutions, please contactPSIRT@huawei.com.

For general problems about Huawei products and solutions, please directly contact Huawei TAC (Huawei Technical Assistance Center) to request the configuration or technical assistance.


2013-07-18 V1.0 INITIAL

This document is provided on an "AS IS" basis and does not imply any kind of guarantee or warranty, either express or implied, including the warranties of merchantability or fitness for a particular purpose. In no event shall Huawei or any of its directly or indirectly controlled subsidiaries or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages. Your use of the document, by whatsoever means, will be totally at your own risk. Huawei is entitled to amend or update this document from time to time.


Complete information for providing feedback on security vulnerability of Huawei products, getting support for Huawei security incident response services, and obtaining Huawei security vulnerability information, is available on Huawei's worldwide website at http://www.huawei.com/en/security/psirt/.